Org.Mentalis.Network

Icmp Documentation

Org.Mentalis.Network Namespace

Namespace hierarchy

The System.Net namespace provides a simple programming interface for many of the protocols used on networks today.

Classes

Class | Description
EchoMessage | Defines an echo ICMP message.
Icmp | Implements the ICMP messaging service.
IcmpMessage | Defines a base ICMP message
InformationMessage | Defines an ICMP message with an ID and a sequence number.

Copyright © 2002, The KPD-Team


EchoMessage Class

Defines an echo ICMP message.

For a list of all members of this type, see EchoMessage Members.

System.Object
IcmpMessage
InformationMessage
EchoMessage

[Visual Basic]
Public Class EchoMessage
   Inherits InformationMessage
[C#]
public class EchoMessage : InformationMessage

Requirements

Namespace: Org.Mentalis.Network Namespace

Assembly: Org.Mentalis.Network.dll

See Also

EchoMessage Members | Org.Mentalis.Network Namespace


EchoMessage Members

Public Instance Constructors

EchoMessage Constructor Initializes a new EchoMessage instance.

Public Instance Properties

CheckSum (inherited from IcmpMessage) | Gets or sets the chacksum for this message.
Code (inherited from IcmpMessage) | Gets or sets the message code.
Data | Gets or sets the data of this message.
Identifier (inherited from InformationMessage) | Gets or sets the identification number.
SequenceNumber (inherited from InformationMessage) | Gets or sets the sequence number.
Type (inherited from IcmpMessage) | Gets or sets the type of the message.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetChecksum (inherited from IcmpMessage) | Calculates the checksum of this message.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectBytes | Serializes the object into an array of bytes.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Private Instance Fields

m_Data Holds the value of the Data property.

See Also

EchoMessage Class | Org.Mentalis.Network Namespace


EchoMessage Constructor

Initializes a new EchoMessage instance.

[Visual Basic]
Public Sub New()
[C#]
public EchoMessage();

See Also

EchoMessage Class | EchoMessage Members | Org.Mentalis.Network Namespace


EchoMessage Fields

The fields of the EchoMessage class are listed below. For a complete list of EchoMessage class members, see the EchoMessage Members topic.

Private Instance Fields

m_Data Holds the value of the Data property.

See Also

EchoMessage Class | Org.Mentalis.Network Namespace


EchoMessage.m_Data Field

Holds the value of the Data property.

[Visual Basic]
Private m_Data As Byte()
[C#]
private byte[] m_Data;

See Also

EchoMessage Class | EchoMessage Members | Org.Mentalis.Network Namespace


EchoMessage Properties

The properties of the EchoMessage class are listed below. For a complete list of EchoMessage class members, see the EchoMessage Members topic.

Public Instance Properties

CheckSum (inherited from IcmpMessage) | Gets or sets the chacksum for this message.
Code (inherited from IcmpMessage) | Gets or sets the message code.
Data | Gets or sets the data of this message.
Identifier (inherited from InformationMessage) | Gets or sets the identification number.
SequenceNumber (inherited from InformationMessage) | Gets or sets the sequence number.
Type (inherited from IcmpMessage) | Gets or sets the type of the message.

See Also

EchoMessage Class | Org.Mentalis.Network Namespace


EchoMessage.Data Property

Gets or sets the data of this message.

[Visual Basic]
Public Property Data As Byte()
[C#]
public byte[] Data {get; set;}

Property Value

An array of bytes that represents the data of this message.

See Also

EchoMessage Class | EchoMessage Members | Org.Mentalis.Network Namespace


EchoMessage Methods

The methods of the EchoMessage class are listed below. For a complete list of EchoMessage class members, see the EchoMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetChecksum (inherited from IcmpMessage) | Calculates the checksum of this message.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectBytes | Serializes the object into an array of bytes.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

EchoMessage Class | Org.Mentalis.Network Namespace


EchoMessage.GetObjectBytes Method

Serializes the object into an array of bytes.

[Visual Basic]
Overrides Public Function GetObjectBytes() As Byte()
[C#]
public override byte[] GetObjectBytes();

Return Value

An array of bytes that represents the ICMP message.

See Also

EchoMessage Class | EchoMessage Members | Org.Mentalis.Network Namespace


Icmp Class

Implements the ICMP messaging service.

For a list of all members of this type, see Icmp Members.

System.Object
Icmp

[Visual Basic]
Public Class Icmp
[C#]
public class Icmp

Remarks

Currently, the implementation only supports the echo message (better known as 'ping').

Requirements

Namespace: Org.Mentalis.Network Namespace

Assembly: Org.Mentalis.Network.dll

See Also

Icmp Members | Org.Mentalis.Network Namespace


Icmp Members

Public Instance Constructors

Icmp Constructor Initializes an instance of the Icmp class.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Ping | Overloaded. Initiates an ICMP ping with a timeout of 1000 milliseconds.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

ClientSocket | Gets or sets the Socket that is used to communicate with the remote server.
HasTimedOut | Gets or sets a value that indicates whether the ping has timed out or not.
Host | Gets or sets the address of the remote host to communicate with.
PingTimeOut | Gets or sets the timer that triggers the PingTimedOut method.
StartTime | Gets or sets the time when the ping began/begins.

Protected Instance Methods

Finalize | Releases all the resources.
GetEchoMessageBuffer | Generates the Echo message to send.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
PingTimedOut | Called when the ping method times out.

Private Instance Fields

m_ClientSocket | Stores the value of the ClientSocket property.
m_HasTimedOut | Stores the value of the HasTimedOut property.
m_Host | Stores the value of the Host property.
m_PingTimeOut | Stores the value of the PingTimeOut property.
m_StartTime | Stores the value of the StartTime property.

See Also

Icmp Class | Org.Mentalis.Network Namespace


Icmp Constructor

Initializes an instance of the Icmp class.

[Visual Basic]
Public Sub New( _
   ByVal host As System.Net.IPAddress _
)
[C#]
public Icmp(
   IPAddress host
);

Parameters

host
The host that will be used to communicate with.

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp Fields

The fields of the Icmp class are listed below. For a complete list of Icmp class members, see the Icmp Members topic.

Private Instance Fields

m_ClientSocket | Stores the value of the ClientSocket property.
m_HasTimedOut | Stores the value of the HasTimedOut property.
m_Host | Stores the value of the Host property.
m_PingTimeOut | Stores the value of the PingTimeOut property.
m_StartTime | Stores the value of the StartTime property.

See Also

Icmp Class | Org.Mentalis.Network Namespace


Icmp.m_ClientSocket Field

Stores the value of the ClientSocket property.

[Visual Basic]
Private m_ClientSocket As System.Net.Sockets.Socket
[C#]
private Socket m_ClientSocket;

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.m_HasTimedOut Field

Stores the value of the HasTimedOut property.

[Visual Basic]
Private m_HasTimedOut As Boolean
[C#]
private bool m_HasTimedOut;

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.m_Host Field

Stores the value of the Host property.

[Visual Basic]
Private m_Host As System.Net.IPAddress
[C#]
private IPAddress m_Host;

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.m_PingTimeOut Field

Stores the value of the PingTimeOut property.

[Visual Basic]
Private m_PingTimeOut As System.Threading.Timer
[C#]
private Timer m_PingTimeOut;

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.m_StartTime Field

Stores the value of the StartTime property.

[Visual Basic]
Private m_StartTime As Date
[C#]
private DateTime m_StartTime;

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp Properties

The properties of the Icmp class are listed below. For a complete list of Icmp class members, see the Icmp Members topic.

Protected Instance Properties

ClientSocket | Gets or sets the Socket that is used to communicate with the remote server.
HasTimedOut | Gets or sets a value that indicates whether the ping has timed out or not.
Host | Gets or sets the address of the remote host to communicate with.
PingTimeOut | Gets or sets the timer that triggers the PingTimedOut method.
StartTime | Gets or sets the time when the ping began/begins.

See Also

Icmp Class | Org.Mentalis.Network Namespace


Icmp.ClientSocket Property

Gets or sets the Socket that is used to communicate with the remote server.

[Visual Basic]
Protected Property ClientSocket As System.Net.Sockets.Socket
[C#]
protected System.Net.Sockets.Socket ClientSocket {get; set;}

Property Value

A Socket object that is used to communicate with the remote server.

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.HasTimedOut Property

Gets or sets a value that indicates whether the ping has timed out or not.

[Visual Basic]
Protected Property HasTimedOut As Boolean
[C#]
protected bool HasTimedOut {get; set;}

Property Value

A boolean value that indicates whether the ping has timed out or not.

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.Host Property

Gets or sets the address of the remote host to communicate with.

[Visual Basic]
Protected Property Host As System.Net.IPAddress
[C#]
protected System.Net.IPAddress Host {get; set;}

Property Value

An IPAddress instance that specifies the address of the remote host to communicate with.

Exceptions

Exception Type | Condition
System.ArgumentNullException | The specified value is null (Nothing in VB.NET).

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.PingTimeOut Property

Gets or sets the timer that triggers the PingTimedOut method.

[Visual Basic]
Protected Property PingTimeOut As System.Threading.Timer
[C#]
protected System.Threading.Timer PingTimeOut {get; set;}

Property Value

A Timer object that triggers the PingTimedOut method.

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.StartTime Property

Gets or sets the time when the ping began/begins.

[Visual Basic]
Protected Property StartTime As Date
[C#]
protected System.DateTime StartTime {get; set;}

Property Value

A DateTime object that specifies when the ping began.

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp Methods

The methods of the Icmp class are listed below. For a complete list of Icmp class members, see the Icmp Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Ping | Overloaded. Initiates an ICMP ping with a timeout of 1000 milliseconds.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize | Releases all the resources.
GetEchoMessageBuffer | Generates the Echo message to send.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
PingTimedOut | Called when the ping method times out.

See Also

Icmp Class | Org.Mentalis.Network Namespace


Icmp.Finalize Method

Releases all the resources.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.GetEchoMessageBuffer Method

Generates the Echo message to send.

[Visual Basic]
Protected Function GetEchoMessageBuffer() As Byte()
[C#]
protected byte[] GetEchoMessageBuffer();

Return Value

An array of bytes that represents the ICMP echo message to send.

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Ping Method

Icmp Documentation

Icmp.Ping

Initiates an ICMP ping with a timeout of 1000 milliseconds.

Overload List

Initiates an ICMP ping with a timeout of 1000 milliseconds.

public TimeSpan Ping();

Initiates an ICMP ping.

public TimeSpan Ping(int);

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


Icmp.Ping Method ()

Initiates an ICMP ping with a timeout of 1000 milliseconds.

[Visual Basic]
Overloads Public Function Ping() As System.TimeSpan
[C#]
public TimeSpan Ping();

Return Value

A TimeSpan object that holds the time it takes for a packet to travel to the remote server and back. A value of TimeSpan.MaxValue indicates a timeout.

Exceptions

Exception Type | Condition
System.Net.Sockets.SocketException | There was an error while communicating with the remote server.

Example

The following example will ping the server www.mentalis.org ten times and print the results in the Console.

            Icmp icmp = new Icmp(Dns.Resolve("www.mentalis.org").AddressList[0]);
            for (int i = 0; i < 10; i++) {
                Console.WriteLine(icmp.Ping().TotalMilliseconds);
            }

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace | Icmp.Ping Overload List


Icmp.Ping Method (Int32)

Initiates an ICMP ping.

[Visual Basic]
Overloads Public Function Ping( _
   ByVal timeout As Integer _
) As System.TimeSpan
[C#]
public TimeSpan Ping(
   int timeout
);

Parameters

timeout
Specifies the timeout in milliseconds. If this value is set to Timeout.Infinite, the method will never time out.

Return Value

A TimeSpan object that holds the time it takes for a packet to travel to the remote server and back. A value of TimeSpan.MaxValue indicates a timeout.

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace | Icmp.Ping Overload List


Icmp.PingTimedOut Method

Called when the ping method times out.

[Visual Basic]
Protected Sub PingTimedOut( _
   ByVal state As Object _
)
[C#]
protected void PingTimedOut(
   object state
);

Parameters

state
The source of the event. This is an object containing application-specific information relevant to the methods invoked by this delegate, or a null reference (Nothing in Visual Basic).

See Also

Icmp Class | Icmp Members | Org.Mentalis.Network Namespace


IcmpMessage Class

Defines a base ICMP message

For a list of all members of this type, see IcmpMessage Members.

System.Object
IcmpMessage

[Visual Basic]
MustInherit Public Class IcmpMessage
[C#]
public abstract class IcmpMessage

Requirements

Namespace: Org.Mentalis.Network Namespace

Assembly: Org.Mentalis.Network.dll

See Also

IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage Members

Public Instance Constructors

IcmpMessage Constructor Initializes a new IcmpMessage instance.

Public Instance Properties

CheckSum | Gets or sets the chacksum for this message.
Code | Gets or sets the message code.
Type | Gets or sets the type of the message.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetChecksum | Calculates the checksum of this message.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectBytes | Serializes the object into an array of bytes.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Private Instance Fields

m_CheckSum | Holds the value of the CheckSum property.
m_Code | Holds the value of the Code property.
m_Type | Holds the value of the Type property.

See Also

IcmpMessage Class | Org.Mentalis.Network Namespace


IcmpMessage Constructor

Initializes a new IcmpMessage instance.

[Visual Basic]
Public Sub New()
[C#]
public IcmpMessage();

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage Fields

The fields of the IcmpMessage class are listed below. For a complete list of IcmpMessage class members, see the IcmpMessage Members topic.

Private Instance Fields

m_CheckSum | Holds the value of the CheckSum property.
m_Code | Holds the value of the Code property.
m_Type | Holds the value of the Type property.

See Also

IcmpMessage Class | Org.Mentalis.Network Namespace


IcmpMessage.m_CheckSum Field

Holds the value of the CheckSum property.

[Visual Basic]
Private m_CheckSum As System.UInt16
[C#]
private ushort m_CheckSum;

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage.m_Code Field

Holds the value of the Code property.

[Visual Basic]
Private m_Code As Byte
[C#]
private byte m_Code;

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage.m_Type Field

Holds the value of the Type property.

[Visual Basic]
Private m_Type As Byte
[C#]
private byte m_Type;

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage Properties

The properties of the IcmpMessage class are listed below. For a complete list of IcmpMessage class members, see the IcmpMessage Members topic.

Public Instance Properties

CheckSum | Gets or sets the chacksum for this message.
Code | Gets or sets the message code.
Type | Gets or sets the type of the message.

See Also

IcmpMessage Class | Org.Mentalis.Network Namespace


IcmpMessage.CheckSum Property

Gets or sets the chacksum for this message.

[Visual Basic]
Public Property CheckSum As System.UInt16
[C#]
public ushort CheckSum {get; set;}

Property Value

An unsigned short that holds the checksum of this message.

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage.Code Property

Gets or sets the message code.

[Visual Basic]
Public Property Code As Byte
[C#]
public byte Code {get; set;}

Property Value

A byte that specifies the message code.

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage.Type Property

Gets or sets the type of the message.

[Visual Basic]
Public Property Type As Byte
[C#]
public byte Type {get; set;}

Property Value

A byte that specifies the type of the message.

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage Methods

The methods of the IcmpMessage class are listed below. For a complete list of IcmpMessage class members, see the IcmpMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetChecksum | Calculates the checksum of this message.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectBytes | Serializes the object into an array of bytes.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

IcmpMessage Class | Org.Mentalis.Network Namespace


IcmpMessage.GetChecksum Method

Calculates the checksum of this message.

[Visual Basic]
Public Function GetChecksum() As System.UInt16
[C#]
public ushort GetChecksum();

Return Value

An unsigned short that holds the checksum of this ICMP message.

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


IcmpMessage.GetObjectBytes Method

Serializes the object into an array of bytes.

[Visual Basic]
Overridable Public Function GetObjectBytes() As Byte()
[C#]
public virtual byte[] GetObjectBytes();

Return Value

An array of bytes that represents the ICMP message.

See Also

IcmpMessage Class | IcmpMessage Members | Org.Mentalis.Network Namespace


InformationMessage Class

Defines an ICMP message with an ID and a sequence number.

For a list of all members of this type, see InformationMessage Members.

System.Object
IcmpMessage
InformationMessage

[Visual Basic]
Public Class InformationMessage
   Inherits IcmpMessage
[C#]
public class InformationMessage : IcmpMessage

Requirements

Namespace: Org.Mentalis.Network Namespace

Assembly: Org.Mentalis.Network.dll

See Also

InformationMessage Members | Org.Mentalis.Network Namespace


InformationMessage Members

Public Instance Constructors

InformationMessage Constructor Initializes a new InformationMessage instance.

Public Instance Properties

CheckSum (inherited from IcmpMessage) | Gets or sets the chacksum for this message.
Code (inherited from IcmpMessage) | Gets or sets the message code.
Identifier | Gets or sets the identification number.
SequenceNumber | Gets or sets the sequence number.
Type (inherited from IcmpMessage) | Gets or sets the type of the message.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetChecksum (inherited from IcmpMessage) | Calculates the checksum of this message.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectBytes | Serializes the object into an array of bytes.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Private Instance Fields

m_Identifier | Holds the value of the Identifier property.
m_SequenceNumber | Holds the value of the SequenceNumber property.

See Also

InformationMessage Class | Org.Mentalis.Network Namespace


InformationMessage Constructor

Initializes a new InformationMessage instance.

[Visual Basic]
Public Sub New()
[C#]
public InformationMessage();

See Also

InformationMessage Class | InformationMessage Members | Org.Mentalis.Network Namespace


InformationMessage Fields

The fields of the InformationMessage class are listed below. For a complete list of InformationMessage class members, see the InformationMessage Members topic.

Private Instance Fields

m_Identifier | Holds the value of the Identifier property.
m_SequenceNumber | Holds the value of the SequenceNumber property.

See Also

InformationMessage Class | Org.Mentalis.Network Namespace


InformationMessage.m_Identifier Field

Holds the value of the Identifier property.

[Visual Basic]
Private m_Identifier As System.UInt16
[C#]
private ushort m_Identifier;

See Also

InformationMessage Class | InformationMessage Members | Org.Mentalis.Network Namespace


InformationMessage.m_SequenceNumber Field

Holds the value of the SequenceNumber property.

[Visual Basic]
Private m_SequenceNumber As System.UInt16
[C#]
private ushort m_SequenceNumber;

See Also

InformationMessage Class | InformationMessage Members | Org.Mentalis.Network Namespace


InformationMessage Properties

The properties of the InformationMessage class are listed below. For a complete list of InformationMessage class members, see the InformationMessage Members topic.

Public Instance Properties

CheckSum (inherited from IcmpMessage) | Gets or sets the chacksum for this message.
Code (inherited from IcmpMessage) | Gets or sets the message code.
Identifier | Gets or sets the identification number.
SequenceNumber | Gets or sets the sequence number.
Type (inherited from IcmpMessage) | Gets or sets the type of the message.

See Also

InformationMessage Class | Org.Mentalis.Network Namespace


InformationMessage.Identifier Property

Gets or sets the identification number.

[Visual Basic]
Public Property Identifier As System.UInt16
[C#]
public ushort Identifier {get; set;}

Property Value

An unsigned short that holds the identification number of this message.

See Also

InformationMessage Class | InformationMessage Members | Org.Mentalis.Network Namespace


InformationMessage.SequenceNumber Property

Gets or sets the sequence number.

[Visual Basic]
Public Property SequenceNumber As System.UInt16
[C#]
public ushort SequenceNumber {get; set;}

Property Value

An unsigned short that holds the sequence number of this message.

See Also

InformationMessage Class | InformationMessage Members | Org.Mentalis.Network Namespace


InformationMessage Methods

The methods of the InformationMessage class are listed below. For a complete list of InformationMessage class members, see the InformationMessage Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetChecksum (inherited from IcmpMessage) | Calculates the checksum of this message.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectBytes | Serializes the object into an array of bytes.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

InformationMessage Class | Org.Mentalis.Network Namespace


InformationMessage.GetObjectBytes Method

Serializes the object into an array of bytes.

[Visual Basic]
Overrides Public Function GetObjectBytes() As Byte()
[C#]
public override byte[] GetObjectBytes();

Return Value

An array of bytes that represents the ICMP message.

See Also

InformationMessage Class | InformationMessage Members | Org.Mentalis.Network Namespace


Mentalis.org License

Org.Mentalis.Network.* namespaces documentation

Source Code License

Copyright © 2002, The KPD-Team
All rights reserved.
http://www.mentalis.org/

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:

- Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

- Neither the name of the KPD-Team, nor the names of its contributors
may be used to endorse or promote products derived from this
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.


Org.Mentalis.NetworkHierarchy

Icmp Documentation

Org.Mentalis.Network Hierarchy

System.Object
-Icmp
-IcmpMessage
-InformationMessage
-EchoMessage